TrustVault access issues
Incident Report for Bitpanda Custody Ltd
Resolved
We have fixed the issue and systems are now operational
Posted Sep 30, 2022 - 13:38 UTC
Identified
We have identified an issue with accessing TrustVault, both via iOS and Web. We are working on a fix at the moment
Posted Sep 30, 2022 - 13:36 UTC
This incident affected: TrustVault, TrustVault Web, and TrustVault API.