Trustvault Metamask broken for Brave and Chrome
Incident Report for Bitpanda Custody Ltd
Resolved
This incident has been resolved.
Posted Jun 17, 2024 - 10:43 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 17, 2024 - 10:42 UTC
Monitoring
Trust Vault MetaMask 11.15 is now live in the Chrome Store. You may notice Metamask no longer opens as it should.

What you need to do to fix:

Re-install the extension by uninstalling it from your browser. Then go to the extension page at https://chromewebstore.google.com/detail/trustvault-metamask/emgcdomdamhpclkofaldlinkhmecjcmc?pli=1 and install it fresh.
Posted Jun 05, 2024 - 15:12 UTC
Update
We will shortly be releasing Trust Vault Metamask 11.15 to resolve these issues.

Unfortunately our testing has shown that it is not a clean upgrade from the current version of Trust Vault Metamask (10.24.2.12).

Please follow the steps below and take a backup of your current Metamask if necessary.

What you need to do:

Soon the update will be going live in the Chrome Store. You may notice Metamask no longer opens as it should. To fix, re-install the extension by first uninstalling it from your browser, then go to the extension page and install it fresh. Please make sure you back up any accounts you use in Metamask before the upgrade.
Posted Jun 04, 2024 - 14:41 UTC
Update
The engineering team has successfully completed the full redevelopment of the TrustVault MetaMask extension. This was a significant accomplishment achieved within a short timeframe. We are now entering an extensive testing phase, and upon its completion, the extension will be submitted to the Chrome Store for approval. We will keep you updated throughout this process.
Posted May 29, 2024 - 08:34 UTC
Update
Our engineers have made significant progress in redeveloping the TrustVault MetaMask extension to be compatible with the recent changes introduced in Chrome and Brave browsers. We hope to provide a timeline for the live update by tomorrow.

Thank you for your continued patience and understanding. We will aim to provide another update by close of business tomorrow, May 24th.
Posted May 27, 2024 - 15:22 UTC
Update
Our engineers continue to diligently work on the complex task of redeveloping the TrustVault MetaMask extension to ensure compatibility with the recent upgrades to Chrome and Brave. We appreciate your patience and understanding as we navigate this challenging process.

As a reminder, the following browser versions are currently supported:

Chrome Version: 124.x
Brave Version: 1.65.x

Additionally, the latest version of the Vivaldi browser is confirmed to work with TrustVault for MetaMask where you can also disable automatic updates to maintain compatibility.

We will provide another update by close of business tomorrow, May 24th and apologise for any inconvenience this may have caused. Should you wish to discuss this further or require any assistance in the meantime, please contact help@bitpandacustody.com
Posted May 23, 2024 - 19:01 UTC
Update
Our engineers are diligently working to resolve the issue caused by the recent update to Chrome and Brave, which has affected the functionality of TrustVault for MetaMask. While we don't have a specific timeline for the fix yet, please be assured that this is our top priority.

In the meantime, you can use a previous version of Chrome or Brave, or switch to the latest version of Vivaldi, to continue conducting DeFi transactions with TrustVault for MetaMask.

We apologise for the ongoing inconvenience and appreciate your patience.
Posted May 22, 2024 - 15:40 UTC
Update
We have tested TrustVault in the latest version of Vivaldi (6.7.3329.31) and confirmed it is working. It is also possible to turn OFF automatic updates with Vivaldi which we would recommend.

If you are unable to use Trustvault MM extension as your Chrome or Brave browsers have automatically updated, we recommend downloading and installing Vivaldi or reverting to previous working versions of Chrome or Brave.

We will also update the article below as and when we have further information whilst our engineers are working to resolve this as speedily as possible. We apologise again for the inconvenience this has caused.

https://help.bitpandacustody.com/en/articles/9360597-trustvault-metamask-brave-chrome
Posted May 22, 2024 - 10:19 UTC
Identified
We have identified an issue with both Brave and Chrome following a recent update.

Please note that TrustVault for MetaMask is currently not working on the latest versions ie Chrome version: 125.x or Brave version 1.66.x

Users are advised to not upgrade or to roll back to the previous version ie Chrome Version: 124.x or Brave version 1.65.x to ensure TrustVault compatibility.
Posted May 21, 2024 - 13:18 UTC
This incident affected: TrustVault MetaMask Extension.