Issues with downstream Ethereum node provider
Incident Report for Bitpanda Custody Ltd
Resolved
The third party has reported that this issue is now resolved.
Posted Apr 22, 2022 - 16:12 UTC
Monitoring
Our systems have returned to normal, we will continue to monitor them closely.
Posted Apr 22, 2022 - 15:20 UTC
Update
We are starting to see improvements in the service as the third party works on the fix.
Posted Apr 22, 2022 - 14:59 UTC
Identified
The third party provider has identified the cause of the problem and is working on a fix.
Posted Apr 22, 2022 - 14:24 UTC
Investigating
We are currently experiencing issues do to an incident with our downstream Ethereum node provider. This is causing errors and showing incorrect balances.
The third party is investigating the issue and we will provide further updates as soon as we can.
Posted Apr 22, 2022 - 14:01 UTC
This incident affected: TrustVault, TrustVault Web, TrustVault API, and TrustVault MetaMask Extension.