Performance has returned to normal, we will continue to monitor the issue.
Posted Jun 16, 2021 - 19:01 UTC
Identified
The issue has been identified as a third party provider, who are already implementing a fix. We are already starting to see improvements in the performance.
Posted Jun 16, 2021 - 18:47 UTC
Investigating
We are currently investigating potential performance issues with getting balances and transacting with Ethereum.
Posted Jun 16, 2021 - 18:38 UTC
This incident affected: TrustVault, TrustVault Web, and TrustVault API.