We are continuing to monitor for any further issues.
Posted Dec 11, 2024 - 18:40 UTC
Monitoring
A fix has been implemented and we are now monitoring the results
Posted Dec 11, 2024 - 18:35 UTC
Identified
There is currently an ongoing issue causing ETH & EVM transactions to fail the root cause has been identified and a fix is being implemented, we apologise for any inconvenience caused.
Posted Dec 11, 2024 - 18:11 UTC
This incident affected: TrustVault Web, TrustVault API, and TrustVault MetaMask Extension.